[FFmpeg-devel] [PATCH v7 1/2] lavc/svt_hevc: add libsvt hevc encoder wrapper.

Carl Eugen Hoyos ceffmpeg at gmail.com
Mon Mar 11 11:36:40 EET 2019


2019-03-11 11:28 GMT+01:00, Jing SUN <jing.a.sun at intel.com>:

> +static void free_buffer(SvtContext *svt_enc)
> +{
> +    uint8_t *in_data = (EB_H265_ENC_INPUT *)svt_enc->in_buf.pBuffer;
> +
> +    av_freep(&in_data);
> +}

Is the cast necessary?
Does the variable make the code more readable?
Does the function make the code more readable?

No more comments here, sorry, Carl Eugen


More information about the ffmpeg-devel mailing list