[FFmpeg-devel] [PATCH 3/3] avcodec/cbs_h2645: rename macros to read and write fields with custom range of values

James Almer jamrial at gmail.com
Thu Apr 18 04:20:43 EEST 2019


On 4/16/2019 11:56 PM, James Almer wrote:
> @@ -164,9 +164,9 @@ static int FUNC(profile_tier_level)(CodedBitstreamContext *ctx, RWContext *rw,
>  
>      for (i = 0; i < max_num_sub_layers_minus1; i++) {
>          if (current->sub_layer_profile_present_flag[i]) {
> -            us(2, sub_layer_profile_space[i], 0, 0, 1, i);
> +            ucs(2, sub_layer_profile_space[i], 0, 0, 1, i);
>              flags(sub_layer_tier_flag[i],           1, i);
> -            us(5, sub_layer_profile_idc[i], 0, 31,  1, i);
> +            ucs(5, sub_layer_profile_idc[i], 0, 31,  1, i);
>  
>              for (j = 0; j < 32; j++)
>                  flags(sub_layer_profile_compatibility_flag[i][j], 2, i, j);
> @@ -220,7 +220,7 @@ static int FUNC(profile_tier_level)(CodedBitstreamContext *ctx, RWContext *rw,
>  #undef profile_compatible
>          }
>          if (current->sub_layer_level_present_flag[i])
> -            us(8, sub_layer_level_idc[i], 0, 255, 1, i);
> +            ucs(8, sub_layer_level_idc[i], 0, 255, 1, i);

The last two should have been changed to ubs() in the first patch instead.

Fixed locally.


More information about the ffmpeg-devel mailing list